Home PageFacebookRSS News Feed
PocketGPS
Web
SatNav,GPS,Navigation
Pocket GPS World - SatNavs | GPS | Speed Cameras: Forums

Pocket GPS World :: View topic - Speed-Based Icons for CP6
 Forum FAQForum FAQ   SearchSearch   UsergroupsUsergroups   ProfileProfile   Log in for private messagesLog in for private messages   Log inLog in 

Speed-Based Icons for CP6
Goto page 1, 2  Next
 
Post new topic   Reply to topic    Pocket GPS World Forum Index -> CoPilot Live
View previous topic :: View next topic  
Author Message
iankb
Frequent Visitor


Joined: May 09, 2005
Posts: 283
Location: Reading, UK

PostPosted: Fri Aug 11, 2006 5:35 am    Post subject: Speed-Based Icons for CP6 Reply with quote

I've created some new icons for using with the speed-based camera files. They use the larger 22x22 pixel size as used by TomTom, but are 16-colour icons as required by CoPilot.

These are designed for maximum visibility of the speed, using colour-coding for the different camera types, and do not waste space on camera symbols. For examples, see my avatar.

If anybody wants a copy, send me a PM with an email address.
_________________
Ian

iPaq 2210
Globalsat BT-338
Seidio G2500 Amplified Vent Mount
CoPilot 6, GPS Tuner 4.2, Navio 3.01
BMW 330ci Sport
Back to top
View user's profile Send private message
iankb
Frequent Visitor


Joined: May 09, 2005
Posts: 283
Location: Reading, UK

PostPosted: Mon Aug 14, 2006 1:46 pm    Post subject: Reply with quote

To use the icons in the received zipfile ...
  • Download the monthly files that have a separate OV2 file for each speed and camera type.
  • Replace the supplied BMP files with my set.
  • Rename the OV2 files to match the BMP files (i.e. safetycamera_*.OV2)
  • Install OV2 and BMP files as normal.
The colour codings of the supplied files are ...
  • Black on Yellow = Gatso (i.e. yellow boxes).
  • White on Red = Mobile (i.e. red for danger).
  • Yellow/Blue/Yellow Vertical Bands = Specs (i.e. two yellow cameras separated by open sky).
  • Red/Yellow/Green Horizontal Bands = Redlight (i.e. traffic lights).
  • Black on White = Temp.
And the symbols are either ...
  • Speed.
  • A question mark for Unknown.
  • A tilde (wavy line) for Variable.

_________________
Ian

iPaq 2210
Globalsat BT-338
Seidio G2500 Amplified Vent Mount
CoPilot 6, GPS Tuner 4.2, Navio 3.01
BMW 330ci Sport
Back to top
View user's profile Send private message
bcapo
Occasional Visitor


Joined: Jun 19, 2006
Posts: 7

PostPosted: Fri Aug 18, 2006 5:08 pm    Post subject: Reply with quote

Ian

Have installed your files as suggetsed and I dont get your symbols. Also every saftey camera is anounced about 5 times!!! Any suggestions?
Back to top
View user's profile Send private message
iankb
Frequent Visitor


Joined: May 09, 2005
Posts: 283
Location: Reading, UK

PostPosted: Sat Aug 19, 2006 10:13 am    Post subject: Reply with quote

If loading new camera files, you will need to have removed the previous versions. You need to delete the existing ao*.* files from the Save directory, copy the OV2 and BMP files in, and restart CoPilot. It will create new ao*.* files and automatically delete the OV2 and BMP files. If you have imported any other custom POI files, you will need to reload these again as well.

There were bugs in CP6 that caused the icons and the audio alerts to disappear, but I believe that these have mainly been resolved.

Although the filenames on the PDA have to start with 'safetycamera' to bring up the new camera alerts, the same filenames will stop them appearing on the desktop version. Changing the names for the desktop versions will allow them to appear there as well.
_________________
Ian

iPaq 2210
Globalsat BT-338
Seidio G2500 Amplified Vent Mount
CoPilot 6, GPS Tuner 4.2, Navio 3.01
BMW 330ci Sport
Back to top
View user's profile Send private message
bcapo
Occasional Visitor


Joined: Jun 19, 2006
Posts: 7

PostPosted: Mon Aug 21, 2006 11:21 am    Post subject: OK now Reply with quote

OK didnt realise had to delete ao files. Works fine now tahnks.

Only other thing is that with all those new files i keep getting the " your memory is low" message"!

Will have to try and find some files to delete.
Back to top
View user's profile Send private message
iankb
Frequent Visitor


Joined: May 09, 2005
Posts: 283
Location: Reading, UK

PostPosted: Mon Aug 21, 2006 2:05 pm    Post subject: Reply with quote

Even if all of the bitmap files are loaded into memory at the same time, they only amount to 9KB in total. When not loaded, they will reside on your SD card, so shouldn't affect main memory. If you are short of space on your SD card, then try deleting any old track files that reside in 'My Documents'. You seem to need quite a lot of spare space on the card, since CoPilot seems to use it during runtime, possibly for the TTS voice generation. The symptom I get when I 'run out' of space is that it stops writing the daily track files.
_________________
Ian

iPaq 2210
Globalsat BT-338
Seidio G2500 Amplified Vent Mount
CoPilot 6, GPS Tuner 4.2, Navio 3.01
BMW 330ci Sport
Back to top
View user's profile Send private message
bcapo
Occasional Visitor


Joined: Jun 19, 2006
Posts: 7

PostPosted: Mon Aug 21, 2006 2:24 pm    Post subject: icon files Reply with quote

Thats strange becuase my bmps reside in the PDA in the program files directory not on the storage card. there is plenty of space on the storage card. I have checked and nothing else is running at the same time
Back to top
View user's profile Send private message
Schouten
Regular Visitor


Joined: May 16, 2005
Posts: 86
Location: United Kingdom

PostPosted: Tue Aug 22, 2006 1:47 pm    Post subject: Reply with quote

Ian,

Thanks for the files. Probably a daft question but do you need to do this for each new monthly download for both the .bmp and .ov2 files or can you just rename and load the .ov2 files after the initial installation leaving the bitmaps intact (assuming you only delete the correct ao files each time?)

I'm not sure of the relationship between the two file types i.e. do they normally both change with the monthly updates or just the ov2? Phew!

Thanks
Terry
Back to top
View user's profile Send private message
iankb
Frequent Visitor


Joined: May 09, 2005
Posts: 283
Location: Reading, UK

PostPosted: Tue Aug 22, 2006 2:18 pm    Post subject: Reply with quote

The BMP files do not change, but I don't know if the OV2 files will load without corresponding BMP files. However, it won't hurt to try.

It's possible that CP6 may switch to using a default icon, but I suspect that it might ignore the OV2 files altogether.
_________________
Ian

iPaq 2210
Globalsat BT-338
Seidio G2500 Amplified Vent Mount
CoPilot 6, GPS Tuner 4.2, Navio 3.01
BMW 330ci Sport
Back to top
View user's profile Send private message
declan29
Occasional Visitor


Joined: Jul 04, 2006
Posts: 11

PostPosted: Wed Aug 23, 2006 9:58 pm    Post subject: Icon problems Reply with quote

Hi Ian,

I'm having problems getting these icons to work also. I keep getting the standard icon that CoPilot uses, and not your icons. I've tried deleting all the ao files, and then copying your files in (having renamed the ov2 files to match the bmp's) and restarting CoPilot. However, I keep seeing the same old icon!

Any help you can offer on this would be greatly appreciated.

Kind regards,

Declan.
Back to top
View user's profile Send private message
iankb
Frequent Visitor


Joined: May 09, 2005
Posts: 283
Location: Reading, UK

PostPosted: Fri Aug 25, 2006 1:33 pm    Post subject: Reply with quote

Hi Declan,

Are you using the latest patch, version 6.0.1.68 I think ?

Also, are you using the Map Setting for 'Display POIs' of either 'All POIs' or 'Imported POIs' ? I would expect the 'Default POIs' setting to hide all custom icons, as well as the speed camera updates.
_________________
Ian

iPaq 2210
Globalsat BT-338
Seidio G2500 Amplified Vent Mount
CoPilot 6, GPS Tuner 4.2, Navio 3.01
BMW 330ci Sport
Back to top
View user's profile Send private message
declan29
Occasional Visitor


Joined: Jul 04, 2006
Posts: 11

PostPosted: Fri Aug 25, 2006 6:49 pm    Post subject: Reply with quote

Hi Ian,

Thanks for your reply.

Have the latest patch installed. I have Display POI set to never. I don't use the report on POI feature for the safety cameras, I just use the Safety Alert functionality. Would this be the problem? Or should the icons work correctly with the safety alert function?

I did have display POIs turned on for custom POIs previously, when I was using the old method of safety camera warnings. But I have deleted all the AO files repeatedly without any luck.

Any ideas or is the only option a full uninstall / reinstall (don't think I really want to go through that to be honest.

Kind regards,

Declan.
Back to top
View user's profile Send private message
iankb
Frequent Visitor


Joined: May 09, 2005
Posts: 283
Location: Reading, UK

PostPosted: Fri Aug 25, 2006 10:23 pm    Post subject: Reply with quote

Hi Declan,

While the camera alerts are driven by the specially-named safetycamera*.* files, they are still custom POI's. To display my icons, you must use the standard POI functionality for displaying 'Imported POIs'. My icons do not form part of the camera alert panel, they are 'permanently' displayed on the route.
_________________
Ian

iPaq 2210
Globalsat BT-338
Seidio G2500 Amplified Vent Mount
CoPilot 6, GPS Tuner 4.2, Navio 3.01
BMW 330ci Sport
Back to top
View user's profile Send private message
declan29
Occasional Visitor


Joined: Jul 04, 2006
Posts: 11

PostPosted: Sun Aug 27, 2006 10:28 am    Post subject: Reply with quote

Cool.

Thanks for the help Ian, very much appreciated.

Kind regards,

Declan.
Back to top
View user's profile Send private message
declan29
Occasional Visitor


Joined: Jul 04, 2006
Posts: 11

PostPosted: Sun Aug 27, 2006 7:49 pm    Post subject: Reply with quote

Hi Ian,

Hate to bother you again, but I thought I'd chance my arm with one more question!

I've started using your icons and turned off the Safety Alert functionality (it's essentially useless anyway when it doesn't tell you what the camera type or speed limit is). However, the one thing I do like about the CoPilot default way of doing things is the audible warning (just the little chime is enough, I can do without Jane wittering on).

So, my question is: do you know of any way of integrating an audible warning with your icons? I've had a look through some of the system files myself, without any luck (my skills with code doesn't go much beyond changing the default distance setting to kilometers). But there is surely a control in there that could be tweaked to link the chime to an imported POI...

Fingers crossed you know of some way of doing this (and that I'm not being an idiot and missing something very obvious!).

Kind regards,

Declan.
Back to top
View user's profile Send private message







Posted: Today    Post subject: Pocket GPS Advertising

Back to top
Display posts from previous:   
Post new topic   Reply to topic    Pocket GPS World Forum Index -> CoPilot Live All times are GMT + 1 Hour
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum

Make a Donation



CamerAlert Database

Click here for the PocketGPSWorld.com Speed Camera Database

Download Speed Camera Database
22.042 (10 Apr 24)



WORLDWIDE SPEED CAMERA SPOTTERS WANTED!

Click here to submit camera positions to the PocketGPSWorld.com Speed Camera Database


12mth Subscriber memberships awarded every week for verified new camera reports!

Submit Speed Camera Locations Now


CamerAlert Apps



iOS QR Code






Android QR Code







Terms & Privacy


GPS Shopping